Exetools

Exetools (https://forum.exetools.com/index.php)
-   Developer Section (https://forum.exetools.com/forumdisplay.php?f=48)
-   -   x64dbg (https://forum.exetools.com/showthread.php?t=15328)

Shub-Nigurrath 01-09-2021 09:15

Jumping back to do something, have a question. I left x64dbg several months ago with a foreseen support for plugins. Does it support now? There is a list of good ones floating around?

Thanks
Shub.

atom0s 01-09-2021 10:01

Quote:

Originally Posted by Shub-Nigurrath (Post 122230)
Jumping back to do something, have a question. I left x64dbg several months ago with a foreseen support for plugins. Does it support now? There is a list of good ones floating around?

Thanks
Shub.

Their GitHub has a list maintained here:
https://github.com/x64dbg/x64dbg/wiki/Plugins

There's a handful of others on Github itself that are pretty easy to find too.

Rasmus 01-09-2021 17:31

Quote:

Originally Posted by Shub-Nigurrath (Post 122230)
Jumping back to do something, have a question. I left x64dbg several months ago with a foreseen support for plugins. Does it support now? T

Depends on what you need the plugin to do of course. There are a lot floating around though as atom0s mentioned.

Shub-Nigurrath 01-09-2021 18:12

I mean. With Olly there were some handy distros with pre selected plugins (those really working) or patches to do most of rce stuffs. Anything similar?

Rasmus 01-09-2021 19:39

Quote:

Originally Posted by Shub-Nigurrath (Post 122236)
I mean. With Olly there were some handy distros with pre selected plugins (those really working) or patches to do most of rce stuffs. Anything similar?

Need to make them yourself...

LaDidi 02-10-2021 16:33

@aLL :
Hi all,

Do you know why psr.exe (in Windows) can't be debugged ?
Why x64dbg needs elevation but psr, itself, doesn't need it ?
Moreover, no problem with OllyDbg..

Regards.

Stingered 04-18-2021 03:28

What do you mean by "can't be debugged"? Obviously the owner of X64DBG can answer better, but certain operations, such as setting x64dbg as JIT debugger, require elevation to work. What user context are you running each debugger under? Are you attaching or trying to load PSR EXE from debugger? Several variables... OllyDBG also have requirements and tells you at start of debugger (window pops up) if you are not running under admin context because some operations will fail.


All times are GMT +8. The time now is 01:42.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Always Your Best Friend: Aaron, JMI, ahmadmansoor, ZeNiX