Exetools (https://forum.exetools.com/index.php)
-   General Discussion (https://forum.exetools.com/forumdisplay.php?f=2)
-   -   Asprotect Last Exception (https://forum.exetools.com/showthread.php?t=5158)

britedream 08-29-2004 12:02

Asprotect Last Exception
1 Attachment(s)
This is the new script to bypass the asprotect trick of changing the last exception, I left the old asprotect since we already have script for them, this script should work on most new asprotect without skipping, it is only tested on handful of the new ones, so please feedback , if there is any problem.

script now is updated to include all new asprotect.


britedream 08-29-2004 20:16

Script above is update to include all new asprotect
1 Attachment(s)
it should work on all new asprotect now instead of most, for those who might have problem using the script on non xp pc , you might try the following script, it is identical to the above , except that I use ollyscript.dll to get the code size in instead of taking it from the pe header.


MaRKuS-DJM 08-30-2004 02:46

hey big unpacker! doesn't work on FlashPaste 2.0 Beta (hxxp://flashpaste.softvoile.com)
i think it's hard to get it working for really ALL asprotect

britedream 08-30-2004 07:04

Thanks Markus-DJM
way to go , this is the only way to make the script better,feedback,the script is corrected to your finding, please check it. this is why asprotect has an edge over others, hard to keep up with, you always find different breed. Thanks.

axl936 08-30-2004 10:43

100 % working..
@ britedream :
I have tryed your script.
I have tryed with my appz, and it works very fine now...
It stop my appz at last exception EVERY RUN NOW !!
(win 2000 pre sp5, ollyscript and hideDebug)

Congratulation for your great works !!
Bye and thanx !!

britedream 09-02-2004 05:28

script asplastex_Oepallnew2 has been corrected to work as good as asplastex_Oepallnew.for those who have the old one please change GMI eip,CODESIZE to GMI 401000,CODESIZE. this will make the script works from any address in the packer code .that was a tiny mistake I made ,sorry my knowledge of the script commands are not that great.please forgive my ignorance.Thanks


Maltese 10-18-2004 23:26

Your new script is really nice. Great work. However I have a problem.

I am trying to unpack TheaterTek 2.0 which is protected by AsProtect.

Your script never stops at the last exception. After starting your script, TheaterTek just runs.

Any thoughts?


LaDidi 10-19-2004 15:15

It's a VERY good idea cause Stripper 2.11 RC2 has PB with "new" ASPR and the last exception : Hey Syd, you can do it !....
Best regards.

britedream 10-19-2004 16:04

To maltese
1 Attachment(s)
I really couldn't find your target to download, but my recent script is as below, please, try it , and see if it works.

[notes] this only works on some of the recent asprotect.I didn't get any feedback in order to make it works on many asprotect targets.

script updated oct-23-2004

Maltese 10-19-2004 23:30

Thank you BriteDream for responding.

I tried the new script. No go. I sent you a PM so that you can try the script on the target file to see what I am seeing.


mail-jvc 11-03-2005 20:59

I'm using Stripper since few month now and i found this tool very usefull but the last exception is really a problem, so i tried to find another way to unpack Asprotected progs ( i mean a simple way ) but haven't found. please Help !

All times are GMT +8. The time now is 00:09.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Always Your Best Friend: Aaron, JMI, ahmadmansoor, ZeNiX