Exetools (https://forum.exetools.com/index.php)
-   General Discussion (https://forum.exetools.com/forumdisplay.php?f=2)
-   -   IDA remote debugging problem (https://forum.exetools.com/showthread.php?t=13708)

Av0id 08-08-2011 03:53

IDA remote debugging problem
3 Attachment(s)
Hello community. I have little problem and i hope you help me with it. I'd like to remote debug linux app. I have two VM's installed, first one is winxp sp3, second one is debian6. I've configured both OS's, created share. Now i am trying to start debug. I'm going to debian and starting linux_server from winxp share, then i'm going to winxp, open target in IDA, configured debugger and trying to start debug, then i've got wierd error (file not found, but found - 01.png)

OK, i press Use found and got another error (02.png)

If i press Yes in 02.png i get same error again, if i press No entire process stopped. If i press Copy new in 01.png IDA asked me to select file and then i get 02.png again.

If we return to debian we'll see that connection was successfull and file found by linux_server (03.png).

Please help, what i'm doing wrong?

PS: i'm using this tutorial as base:

Av0id 08-08-2011 13:56

ok, i solved this problem, it seems that linux_server checks file existence by using xstat, which doesn't work with samba mounted shares

for now i have another problem that SIGTTIN can't be passed to application (read from console)

mesagio 08-08-2011 14:42

how did you solved the problem ?

Av0id 08-08-2011 18:51

i just copied my app to local folder and specify it in debugger options

All times are GMT +8. The time now is 00:52.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Always Your Best Friend: Aaron, JMI, ahmadmansoor, ZeNiX