Exetools

Exetools (https://forum.exetools.com/index.php)
-   Developer Section (https://forum.exetools.com/forumdisplay.php?f=48)
-   -   x64dbg (https://forum.exetools.com/showthread.php?t=15328)

mr.exodia 07-27-2014 04:23

@Insid3Code: The problem is with fonts that have an non-ascii character in their name, all the default windows fonts are working fine here...

Greetings

cxj98 07-27-2014 04:34

@Insid3Code

I use fixsys font is working, I think the problem not of your plugin, maybe is x32_dbg.exe not support spcial none-english font.

SLV 07-27-2014 05:32

Nice tool. Add a "make x64_dbg just in time debugger" feature pls in the next version.

Kurapica 07-27-2014 08:07

Thanks for this update.

u_f_o 07-27-2014 20:21

very good work, very useful tool!
i use it on 64-bit systems.
but i cann't use windows symbols with it.
i've downloaded symbols (windows 7 sp1 x64) from microsoft site,
but only 25% symbol was found, 60% mismatched, 15% not found at all.

i would be very glad if x64_dbg will be able to use IDA-map files, as syser.

mr.exodia 07-28-2014 01:38

@u_f_o: You should copy symsrv.dll into the x64_dbg directory and then set the environent variable like this:
Code:

SET _NT_SYMBOL_PATH = symsrv*symsrv.dll*c:\*http://msdl.microsoft.com/download/symbols
Not recommended to use to globally, maybe a .bat file:
Code:

@echo off
SET _NT_SYMBOL_PATH = symsrv*symsrv.dll*c:\symbols*http://msdl.microsoft.com/download/symbols
start x64_dbg.exe "%1"

Greetings

Artic 08-05-2014 01:26

loving the improvements and the progress and finally a x64 debugger.

thanks alot for all the time spend in this project.
looking forward to the next upgrade. ;)

NeWOT 08-05-2014 14:21

It's a great poject. It's always good to see someone working actively on an x64 debugger who also responses/includes community feedback.

Kurapica 08-08-2014 05:45

mr.exodia :

After days of testing the latest version 020, I found it less stable than 019 !!

First, the application threw several "Memory leaks" messages on Shutdown.

It was much slower than 019 and the worst problem was that once I bring the debugger's main window

to front, the debugger freezes and stops responding :(

I tried to debug the same target with version 019 and this problem didn't occur.

the freezing problem also occurs once any breakpoint is created or even reached.

I know that such general description is not very useful, If you need more information then

I will be happy to provide if I can.

mr.exodia 08-09-2014 22:25

V2.1ALPHA is out

Changelog:
http://x64dbg.com/changelog.html

(this post filter is really shit, it doesn't allow me to post the changelog)

Website:
http://x64dbg.com

Greetings,

Mr. eXoDia

SLV 09-11-2014 17:55

Windows XP SP2 x64 bug. When loading 32bit exe eip points to AddressOfEntryPoint+1.

mr.exodia 09-11-2014 18:27

@SLV: XP is supported from SP3 and the debugger doesnt change the entry point, probably your exe does some tricks.

SLV 09-11-2014 22:36

Exe is msie 6 x64.

Computer_Angel 09-13-2014 19:34

Quote:

Originally Posted by mr.exodia (Post 94539)
@SLV: XP is supported from SP3 and the debugger doesnt change the entry point, probably your exe does some tricks.

Hi exodia,

How could I load application to x64dbg with argument ??? I Could not find any place to put argument in x64dbg ?

mr.exodia 09-14-2014 02:02

@Computer_Angel: Currently we are working on a feature to directly set the commandline from within the application, but now you have to use the InitDebug command.

We hope to be releasing an improved version of x64_dbg soon, no promises though.

Greetings,

Mr. eXoDia


All times are GMT +8. The time now is 15:13.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Always Your Best Friend: Aaron, JMI, ahmadmansoor, ZeNiX