View Single Post
  #9  
Old 12-06-2015, 23:05
Storm Shadow's Avatar
Storm Shadow Storm Shadow is offline
Family
 
Join Date: Jun 2014
Posts: 274
Rept. Given: 189
Rept. Rcvd 191 Times in 78 Posts
Thanks Given: 131
Thanks Rcvd at 205 Times in 70 Posts
Storm Shadow Reputation: 100-199 Storm Shadow Reputation: 100-199
Yes you have to install spesielt Build of PyQt.
Normal build wont work.

have Builded the latest Qt PyQt-win-gpl-4.11.4 framwork from scratch.
Then made a installer that install it correct and add the right path so ida will find it.
PAckage include full PyQt4 version PyQt-win-gpl-4.11.4
And sip sip-4.16.9 that PyQt4 depends on.


Works with any path now

Since many have trouble setting up python correct.
It add following regestry changes to path so ida pro will find PyQt.
Only added if its not there.

https://mega.nz/#!PkN0hSYR!DuYRLKTpcqI5UO0iYw9cvwOQajsQs6XB3_Up9OwdBac

original thread http://www.techbliss.org/threads/pyqt-win-gpl-4-11-qt-4-4-8-7-for-ida-pro-total-package-installer-by-storm-shadow.768/


yes thats correct
Quote:
i have now in

C:\Program Files (x86)\IDA 6.8\plugins\Code editor

the files
pyeditor.py
__init__.py
.icons
idc.api
python.api
idaapi.api

in

C:\Program Files (x86)\IDA 6.8\plugins\

i have

Python_editor.py

is right
__________________
The devil whispered in my ear, "you're not strong enough to withstand the storm."

Today I whispered in the devils ear, "I am the storm."

Last edited by Storm Shadow; 12-06-2015 at 23:17.
Reply With Quote