Exetools  

Go Back   Exetools > General > General Discussion

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2013, 08:31
rcer rcer is offline
Friend
 
Join Date: Dec 2008
Posts: 131
Rept. Given: 5
Rept. Rcvd 7 Times in 6 Posts
Thanks Given: 4
Thanks Rcvd at 14 Times in 14 Posts
rcer Reputation: 7
Compile eror

I am trying to build lmcrypt on \i86_n3-11.9.1and am getting the following compile error.
I extensively googled this subject, but could not find any solution to this problem.

Any ideas or suggestions are welcome.


Setting environment for using Microsoft Visual Studio 2010 x86 tools.

c:\Program Files\Microsoft Visual Studio 10.0\VC>cd C:\Program Files\Flexlm\i86_
n3-11.9.1\i86_n3

C:\Program Files\Flexlm\i86_n3-11.9.1\i86_n3>build

C:\Program Files\Flexlm\i86_n3-11.9.1\i86_n3>echo off
***************************************************************************
Build.bat can be used in 3 ways *
build MT - This builds all of the files using the /MT compiler flag *
( Multi-threaded C Runtime as a static library ) *
build MD - This builds all of the files using the /MD compiler flag *
( Multi-threaded C Runtime as a DLL ) *
build DLL - This build all of the files to use the flexlm dll *
***************************************************************************

Building using the /MT flag

Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
Copyright (C) Microsoft Corporation. All rights reserved.

RC -r -fo scplmd.res scplmd.rc
Microsoft (R) Windows (R) Resource Compiler Version 6.1.7600.16385
Copyright (C) Microsoft Corporation. All rights reserved.

fatal error RC1109: error creating scplmd.res
NMAKE : fatal error U1077: '"c:\Program Files\Microsoft SDKs\Windows\v7.0A\bin\R
C.EXE"' : return code '0x1'
Stop.
C:\Program Files\Flexlm\i86_n3-11.9.1\i86_n3>

regards

rcer
Reply With Quote
  #2  
Old 06-22-2013, 15:17
Kerlingen Kerlingen is offline
VIP
 
Join Date: Feb 2011
Posts: 302
Rept. Given: 0
Rept. Rcvd 274 Times in 97 Posts
Thanks Given: 0
Thanks Rcvd at 260 Times in 78 Posts
Kerlingen Reputation: 200-299 Kerlingen Reputation: 200-299 Kerlingen Reputation: 200-299
Wild guess: You installed the source code in the "Program Files" directory which is by default read-only to all users expect admin, so the command line tools have no write rights and will fail instantly.
Reply With Quote
  #3  
Old 06-22-2013, 19:26
rcer rcer is offline
Friend
 
Join Date: Dec 2008
Posts: 131
Rept. Given: 5
Rept. Rcvd 7 Times in 6 Posts
Thanks Given: 4
Thanks Rcvd at 14 Times in 14 Posts
rcer Reputation: 7
Hi Kerlingen,

Your guess is right, but I have been running the command line as administrator, and I have checked that read & write access is O.K.

Anyway just to run a check I copied the SDK to the D drive, and I did get the same result.

From all the Googling I did, I understand that the problem is related to incorrectly set environment variables, but I haven't been able to figure out which variable(s) need to be set, and with what values?


regards

rcer
Reply With Quote
  #4  
Old 06-22-2013, 22:00
dirkmill dirkmill is offline
Friend
 
Join Date: Jul 2004
Posts: 24
Rept. Given: 0
Rept. Rcvd 0 Times in 0 Posts
Thanks Given: 0
Thanks Rcvd at 1 Time in 1 Post
dirkmill Reputation: 0
hi rcer,

I don't have the 11.9.1 here atm but in my older makefiles (11.4) the only section using the resource compiler is
Code:
buildmsgfile
is that the same for you or do you see additional uses of
Code:
$(RC) -r -fo
?
what values are the variables
Code:
EVENTLOGMESSAGEFILE
EVENTLOGMESSAGEFILE2
set to ?

cheers,

dirkmill :B
Reply With Quote
  #5  
Old 06-22-2013, 22:27
dirkmill dirkmill is offline
Friend
 
Join Date: Jul 2004
Posts: 24
Rept. Given: 0
Rept. Rcvd 0 Times in 0 Posts
Thanks Given: 0
Thanks Rcvd at 1 Time in 1 Post
dirkmill Reputation: 0
too late to edit my previous post

I just checked 11.9.1 i86_n3 out and initially got the same error message.
you basically have two options:
1. create a (potentially empty) resource file for your vendor daemon
2. edit the makefile to skip compiling and linking of the resource file for the vendor daemon

for option two just use the following as replacement of the daemon-section of your makefile:
Code:
daemon:	$(DAEMON)

$(DAEMON): $(XTRAOBJS) $(DAEMONLIBS) lsvendor.obj $(SRCDIR)\lsserver.h $(LMNEW_OBJ)
#	   $(RC) -r -fo $(VENDORNAME).res $(VENDORNAME).rc
           $(LD) /subsystem:console /out:$(DAEMON) lsvendor.obj $(LMNEW_OBJ) \
#          	$(XTRAOBJS) $(DAEMONLIBS) $(CRT_LIB) $(XTRALIB1) $(DONGLELIB) $(ACTSTUB) $(VENDORNAME).res
           	$(XTRAOBJS) $(DAEMONLIBS) $(CRT_LIB) $(XTRALIB1) $(DONGLELIB) $(ACTSTUB) 
			$(EMBED_MANIFEST)
cheers,

dirkmill :B
Reply With Quote
  #6  
Old 06-23-2013, 05:16
Git's Avatar
Git Git is offline
Old Git
 
Join Date: Mar 2002
Location: Torino
Posts: 1,088
Rept. Given: 219
Rept. Rcvd 265 Times in 157 Posts
Thanks Given: 81
Thanks Rcvd at 204 Times in 120 Posts
Git Reputation: 200-299 Git Reputation: 200-299 Git Reputation: 200-299
Use the VC command shell (under Visual Studio Tools menu). It will set up it's paths for you. You can the CD to the flexlm directory.

Git
Reply With Quote
  #7  
Old 06-23-2013, 15:20
rcer rcer is offline
Friend
 
Join Date: Dec 2008
Posts: 131
Rept. Given: 5
Rept. Rcvd 7 Times in 6 Posts
Thanks Given: 4
Thanks Rcvd at 14 Times in 14 Posts
rcer Reputation: 7
Hi Dirkmill,

thanks for pointing me in the right direction, but when I change the makefile as per your suggestion, the compliler only builds the vendor daemon, and nothing else.

If I don't apply the change, I get the error message, and the compliler builds

lmcrypt.

regards

rcer
Reply With Quote
  #8  
Old 06-24-2013, 02:53
dirkmill dirkmill is offline
Friend
 
Join Date: Jul 2004
Posts: 24
Rept. Given: 0
Rept. Rcvd 0 Times in 0 Posts
Thanks Given: 0
Thanks Rcvd at 1 Time in 1 Post
dirkmill Reputation: 0
hi rcer,
option "2" above only requires you to change two lines of your makefile, compilation of the whole kit works as before...
option "1" is even simpler, just create a zero-byte file called
Code:
$(VENDORNAME).rc
in your case this would be
Code:
scplmd.rc
cheers,
dirkmill
Reply With Quote
  #9  
Old 06-25-2013, 18:21
rcer rcer is offline
Friend
 
Join Date: Dec 2008
Posts: 131
Rept. Given: 5
Rept. Rcvd 7 Times in 6 Posts
Thanks Given: 4
Thanks Rcvd at 14 Times in 14 Posts
rcer Reputation: 7
Hi dirkmill,

Yes both options for building the kit are working fine.

Thanks & regards

rcer
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's the regular SDK compile flow with ECC check? bridgeic General Discussion 1 08-29-2014 09:14
How to fix these three RadASM compile errors? bridgeic General Discussion 39 04-10-2013 12:32
how to compile windows NT4/2000? jonwil General Discussion 9 09-05-2004 10:30


All times are GMT +8. The time now is 03:25.


Always Your Best Friend: Aaron, JMI, ahmadmansoor, ZeNiX
( 1998 - 2020 )